summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09e51b2d003d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+pkgname=smtpdane
+pkgver=0.3.0
+pkgrel=1
+pkgdesc='SMTP DANE testing tool'
+arch=('x86_64')
+url="https://github.com/PennockTech/smtpdane"
+license=('MIT')
+makedepends=('go-pie')
+source=("https://github.com/PennockTech/$pkgname/archive/v$pkgver.zip")
+sha256sums=('18804344d472a6aab1a1f307170f461c69183d46d13c235d177a44cbd18ae028')
+
+
+prepare(){
+ mkdir -p gopath/src/go.pennock.tech
+ ln -rTsf $pkgname-$pkgver gopath/src/go.pennock.tech/$pkgname
+ export GOPATH="$srcdir"/gopath
+ go get github.com/miekg/dns
+ go get golang.org/x/crypto/ocsp
+}
+
+
+build() {
+ cd $pkgname-$pkgver
+ export GOPATH="$srcdir"/gopath
+
+ go build \
+ -gcflags "all=-trimpath=$PWD" \
+ -asmflags "all=-trimpath=$PWD" \
+ -ldflags "-extldflags $LDFLAGS" \
+ -o $pkgname .
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+}