summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ed37416332c1..6580a9f66d1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=snakemake
pkgver=4.5.1
-pkgrel=2
+pkgrel=3
pkgdesc='Python-based language and execution environment for GNU Make-like workflows'
arch=(any)
url='https://snakemake.readthedocs.io'
@@ -32,8 +32,10 @@ build() {
package() {
cd "$srcdir/$pkgname-$pkgver"
- python setup.py install --skip-build -O1 --root="$pkgdir"
+ python setup.py install --skip-build -O1 --root="$pkgdir" || exit 1
+ local pyver=$(python -c 'import sys; print("{}.{}".format(*sys.version_info[:2]))')
install -d "$pkgdir/etc/bash_completion.d"
- "$pkgdir/usr/bin/snakemake" --bash-completion >"$pkgdir/etc/bash_completion.d/snakemake"
+ PYTHONPATH="$PKGDIR/usr/lib/python$pyver/site-packages:$PYTHONPATH" \
+ "$pkgdir/usr/bin/snakemake" --bash-completion >"$pkgdir/etc/bash_completion.d/snakemake"
}