summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a056bb72379..c92e6bb9beb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ depends=('squashfs-tools' 'libseccomp' 'libsystemd' 'apparmor')
optdepends=('bash-completion: bash completion support'
'xdg-desktop-portal: desktop integration')
pkgver=2.51.3
-pkgrel=1
+pkgrel=2
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
url="https://github.com/snapcore/snapd"
license=('GPL3')
@@ -17,8 +17,15 @@ makedepends=('git' 'go' 'go-tools' 'libseccomp' 'libcap' 'systemd' 'xfsprogs' 'p
conflicts=('snap-confine')
options=('!strip' 'emptydirs')
install=snapd.install
-source=("$pkgname-$pkgver.tar.xz::https://github.com/snapcore/${pkgname}/releases/download/${pkgver}/${pkgname}_${pkgver}.vendor.tar.xz")
-sha256sums=('67d3701b52484d7dba9c7b122752429eafbb20a0182966dd44ab1b1f6c1b780e')
+source=(
+ "$pkgname-$pkgver.tar.xz::https://github.com/snapcore/${pkgname}/releases/download/${pkgver}/${pkgname}_${pkgver}.vendor.tar.xz"
+ # cherry-picked from https://github.com/snapcore/snapd/pull/10567/
+ "0001-snap-squashfs-handle-squashfs-tools-4.5.patch"
+)
+sha256sums=(
+ '67d3701b52484d7dba9c7b122752429eafbb20a0182966dd44ab1b1f6c1b780e'
+ '8142631da873d49d9b7d32b78afcededf347199f9f42161b88213f9aef33ab82'
+)
_gourl=github.com/snapcore/snapd