summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a5ad0f77eb5..6ec54f868e15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc="Service and tools for management of snap packages."
depends=('squashfs-tools' 'libseccomp' 'libsystemd' 'apparmor')
optdepends=('bash-completion: bash completion support')
pkgver=2.42
-pkgrel=1
+pkgrel=2
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
url="https://github.com/snapcore/snapd"
license=('GPL3')
@@ -37,6 +37,9 @@ prepare() {
build() {
cd "$pkgname-$pkgver"
export GOPATH="$srcdir/go"
+ # snapd does not use modules, setting GO111MODULE=on in the environment breaks
+ # the build
+ unset GO111MODULE
export CGO_ENABLED="1"
export CGO_CFLAGS="${CFLAGS}"
@@ -87,6 +90,9 @@ build() {
package() {
cd "$pkgname-$pkgver"
export GOPATH="$srcdir/go"
+ # snapd does not use modules, setting GO111MODULE=on in the environment breaks
+ # the build
+ unset GO111MODULE
# Install bash completion
install -Dm644 data/completion/snap \