summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 033940a2ecaa..e2d768af651e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,21 @@
-# Maintainer: BenObiWan <benobiwan @t gmail dot com>
+# Maintainer: MCMic <come@chilliet.eu>
+# Contributor: MCMic <come@chilliet.eu>
# Contributor: Sam101 <zoetrem @t gmail dot com>
# Contributor: BenObiWan <benobiwan @t gmail dot com>
# Contributor: Huulivoide
# Contributor: Fernando Carmona Varo <ferkiwi @t gmail dot com>
+
pkgname=solarus
-pkgver=1.6.0
+pkgver=1.6.2
pkgrel=1
epoch=
-pkgdesc="An open-source Zelda-like 2D game engine used by the games zsxd and zsdx."
+pkgdesc="A lightweight, free and open-source game engine for Action-RPGs"
arch=('i686' 'x86_64')
url="http://www.solarus-games.org/"
license=('GPL')
groups=()
depends=('luajit' 'sdl2_image' 'sdl2_ttf' 'physfs' 'openal' 'libvorbis' 'libmodplug' 'qt5-tools' 'qt5-base' 'libglvnd')
-makedepends=('cmake' 'zip')
+makedepends=('cmake')
checkdepends=()
optdepends=('zsxd' 'zsdx' 'zelda-roth-se')
provides=('solarus-engine')
@@ -23,19 +25,19 @@ backup=()
options=()
install=
changelog=
-source=(http://solarus-games.org/downloads/$pkgname/$pkgname-$pkgver-src.tar.gz)
+source=("https://gitlab.com/solarus-games/${pkgname}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz")
noextract=()
-md5sums=('c7d81c934109520cac39b9c9e434059d')
+md5sums=('f5ea8ccddb3d26136b5de51e255e991f')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
+ cd "${srcdir}/${pkgname}-v${pkgver}"
+
cmake -D CMAKE_INSTALL_PREFIX="/usr" -D CMAKE_BUILD_TYPE=Release -D DEFAULT_QUEST=/usr/share/solarus/zsdx .
make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-v${pkgver}"
make DESTDIR="${pkgdir}/" PREFIX="/usr" install
}