summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD57
1 files changed, 33 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d6977e8e9473..7f921e2f6d06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,58 @@
-# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Maintainer : silverhikari <kerrickethan@gmail.com>
+# Contributor: Qontinuum <qontinuum.dev@protonmail.ch>
+# Contributor: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
# Contributor: Fernando Carmona Varo <ferkiwi @t gmail dot com>
# Contributor: BenObiWan <benobiwan @t gmail dot com>
pkgname=solarus-git
-pkgver=1.5.0.r81.gd0601b4
-pkgrel=1
-pkgdesc="An open-source Zelda-like 2D game engine used by the games zsxd and zsdx (development version)"
+pkgver=1.5.3.r1446.g2593c31de
+pkgrel=2
+pkgdesc="An open-source adventure 2D game engine (git version)"
arch=('i686' 'x86_64')
-url="http://www.solarus-engine.org/"
+url="http://www.solarus-games.org/"
license=('GPL3')
-depends=('sdl2_image' 'sdl2_ttf' 'luajit' 'physfs' 'openal' 'libmodplug' 'libvorbis')
+depends=('glm'
+ 'hicolor-icon-theme'
+ 'libmodplug'
+ 'libvorbis'
+ 'luajit'
+ 'openal'
+ 'physfs'
+ 'qt5-base'
+ 'qt5-tools'
+ 'sdl2>=2.0.6'
+ 'sdl2_image'
+ 'sdl2_ttf')
makedepends=('git' 'cmake')
-optdepends=('zsxd-git: Free 2D Zelda fangame Quest'
- 'zsdx-git: Free 2D Zelda fangame Quest with humoristic characters')
-provides=('solarus-engine' 'solarus')
+provides=('solarus')
conflicts=('solarus')
-source=($pkgname::'git+https://github.com/christopho/solarus.git')
+source=('git+https://gitlab.com/solarus-games/solarus.git')
md5sums=('SKIP')
pkgver() {
- cd $pkgname
- local _tag=$(git tag -l 'v*' | sort -r | head -n1 | tr -cd 0-9.)
- local _rev=$(git rev-list --count v${_tag}..HEAD)
- local _hash=$(git rev-parse --short HEAD)
- printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash"
+ cd "${pkgname%-git}"
+ git describe --long --tag | sed 's/v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd $pkgname
-
- rm -rf build
- mkdir build
+ cmake -B build -S "${pkgname%-git}" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
+ cmake --build build
}
build() {
- cd $pkgname/build
-
- cmake .. -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_BUILD_TYPE=Release
+ cd build
make
}
check() {
- make -C $pkgname/build test
+ cd build
+ make
}
package() {
- make -C $pkgname/build DESTDIR="$pkgdir/" install
+ cd build
+ make DESTDIR="$pkgdir/" install
}