summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5ca63feaa352..91ea7cbd47df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,19 @@
# Co-Maintainer: Christian Pinedo <christian (at) chrpinedo (dot) me>
pkgname=solarwallet
_pkgname="Solar Wallet"
-pkgver=0.25.2
+pkgver=0.25.3
pkgrel=1
pkgdesc="Wallet for the Stellar payment network by SatoshiPay."
-arch=('any')
+arch=('x86_64')
url="https://solarwallet.io"
license=('MIT')
-depends=('libnotify' 'nss' 'libxss' 'libxtst' 'xdg-utils' 'libappindicator-gtk3' 'libsecret')
+depends=('libxss' 'lib32-gcc-libs' 'libsodium' 'nss' 'gtk3')
makedepends=('npm')
conflicts=('satoshipay-stellar-wallet')
replaces=('satoshipay-stellar-wallet')
source=("$pkgname-$pkgver.tar.gz::https://github.com/satoshipay/solar/archive/v$pkgver.tar.gz"
"$pkgname.desktop")
-sha256sums=('d677dde1d057a439313e47b4945f4b45a607ed7978a675bd15ad4bad1aabd7ef'
+sha256sums=('dd8f22d4913c41e191eba5812892974913af0fc7e27839c7e0dff4c010566429'
'b6c574362d009c52ab9f9b0bdb4b2af9f1a8f79f0c8f68b897e9a19df46abc75')
build() {
@@ -30,7 +30,7 @@ package() {
install -dm755 "$pkgdir/"{opt/"$_pkgname",usr/bin}
# Remove files for other platforms
- rm -rf electron/dist/linux-unpacked/resources/app.asar.unpacked/node_modules/sodium-native/prebuilds/{darwin*,win32*}
+ rm -rf electron/dist/linux-unpacked/resources/app.asar.unpacked/node_modules/sodium-native/prebuilds/darwin*,linux-arm,win32*}
# Copy main files
cp -a electron/dist/linux-unpacked/* "$pkgdir/opt/$_pkgname"