summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6769d3aab7b8..90fd67405901 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Lucas Melo <luluco250 at gmail dot com>
pkgname=soniccd-git
-pkgver=r423.f0d510c
+pkgver=r476.972e89f
pkgrel=1
pkgdesc='A full decompilation of Sonic CD 2011, based on the PC remake with
improvements & tweaks from the mobile remakes.'
@@ -9,15 +9,17 @@ arch=('any')
url='https://github.com/Rubberduckycooly/Sonic-CD-11-Decompilation'
license=('custom:RSDKv3/4 Decompilation Source Code License v1')
makedepends=('git')
-depends=('sdl2' 'libogg' 'libtheora' 'libvorbis' 'tinyxml2')
+depends=('sdl2' 'libogg' 'libtheora' 'libvorbis')
provides=(soniccd)
source=(
"git+${url}.git"
+ 'git+https://github.com/leethomason/tinyxml2.git'
'soniccd-launcher'
'soniccd.desktop'
)
sha256sums=(
'SKIP'
+ 'SKIP'
'b70b6526c137859385234a19d1935e089c3c6a71639f42f7d579135579e8243b'
'5ef3e25f5391707fdc461a8c25817ddde38a1d34d125dc5b3c43f706b889ed8a'
)
@@ -28,6 +30,13 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$srcdir/Sonic-CD-11-Decompilation"
+ git submodule init
+ git submodule set-url -- dependencies/all/tinyxml2 "$srcdir/tinyxml2"
+ git submodule update dependencies/all/tinyxml2
+}
+
build() {
cd "$srcdir/Sonic-CD-11-Decompilation"
make ${MAKEFLAGS:--j$(nproc)} # CXXFLAGS=O2