summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 2 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e7b2f0593f05..6769d3aab7b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Lucas Melo <luluco250 at gmail dot com>
pkgname=soniccd-git
-pkgver=r377.907d631
+pkgver=r423.f0d510c
pkgrel=1
pkgdesc='A full decompilation of Sonic CD 2011, based on the PC remake with
improvements & tweaks from the mobile remakes.'
@@ -9,17 +9,15 @@ arch=('any')
url='https://github.com/Rubberduckycooly/Sonic-CD-11-Decompilation'
license=('custom:RSDKv3/4 Decompilation Source Code License v1')
makedepends=('git')
-depends=('sdl2' 'libogg' 'libtheora' 'libvorbis')
+depends=('sdl2' 'libogg' 'libtheora' 'libvorbis' 'tinyxml2')
provides=(soniccd)
source=(
"git+${url}.git"
- 'git+https://github.com/leethomason/tinyxml2.git'
'soniccd-launcher'
'soniccd.desktop'
)
sha256sums=(
'SKIP'
- 'SKIP'
'b70b6526c137859385234a19d1935e089c3c6a71639f42f7d579135579e8243b'
'5ef3e25f5391707fdc461a8c25817ddde38a1d34d125dc5b3c43f706b889ed8a'
)
@@ -30,10 +28,6 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- ln -sfn "$srcdir/tinyxml2" "$srcdir/Sonic-CD-11-Decompilation/dependencies/all/tinyxml2"
-}
-
build() {
cd "$srcdir/Sonic-CD-11-Decompilation"
make ${MAKEFLAGS:--j$(nproc)} # CXXFLAGS=O2