summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f315d0c0896f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Teteros <teteros -at- openmailbox -dot- org>
+
+_pkgname=Soundpipe
+pkgname=soundpipe
+pkgver=1.5.0
+pkgrel=1
+pkgdesc="A lightweight music DSP library."
+arch=(any)
+url="http://paulbatchelor.github.io/proj/soundpipe.html"
+license=(MIT)
+makedepends=(libsndfile)
+source=("https://github.com/PaulBatchelor/${pkgname}/archive/v${pkgver}.tar.gz")
+md5sums=('e9bd3c1f2b47f05a76cc89e47f2f68b1')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ PREFIX="${pkgdir}/usr" make install -e
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}