summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 6 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 400a70ad9c1f..b3f5d368079c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,15 @@
# Maintainer: Clarence <xjh.azzbcc@gmail.com>
_pkgname=spandsp
-pkgname=(${_pkgname}-fs ${_pkgname}-docs)
+pkgname=${_pkgname}-fs
pkgver=3.0.0
pkgrel=1
pkgdesc="A DSP library for telephony (FreeSWITCH version)"
arch=('x86_64')
+depends=('libtiff')
+provides=('spandsp')
+conflicts=('spandsp')
url="https://github.com/freeswitch/spandsp"
license=('LGPL' 'GPL')
-makedepends=('gawk' 'doxygen')
source=("git+https://github.com/freeswitch/$_pkgname")
sha256sums=('SKIP')
@@ -19,33 +21,13 @@ pkgver() {
build() {
cd "$_pkgname"
./autogen.sh
- ./configure --prefix=/usr --disable-static --enable-doc
+ ./configure --prefix=/usr --disable-static
make -C src
}
-#
-#check() {
-# cd "$_pkgname"
-# make check
-#}
-
-package_spandsp-fs() {
- depends=('libtiff')
- optdepends=('spandsp-docs: Documentation')
- provides=('spandsp')
- conflicts=('spandsp')
+package() {
cd "$_pkgname"
make DESTDIR="$pkgdir" -C src install
make DESTDIR="$pkgdir" install-pkgconfigDATA
}
-package_spandsp-docs() {
- pkgdesc="A DSP library for telephony documentation (FreeSWITCH version)"
-
- cd "$_pkgname"
- make -C doc
-
- install -dm755 "${pkgdir}/usr/share/doc/$_pkgname/html"
- cp -r "doc/api/html" "${pkgdir}/usr/share/doc/$_pkgname/html/api"
- cp -r "doc/t38_manual" "${pkgdir}/usr/share/doc/$_pkgname/html/t38_manual"
-}