summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cc9008bf387a..c99f37c35fa9 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
-# Contributor: Cyberpunk <apocalipsisfull-2011@outlook.com>
-# Maintainer: Cyberpunk <apocalipsisfull-2011@outlook.com>
+# Contributor: Cyberpunk <aur_linuxero@outlook.com>
+# Maintainer: Cyberpunk <aur_linuxero@outlook.com>
pkgname=sparta
-_pkgname=master
-pkgver=1.0.2beta
+pkgver=1.0.1
pkgrel=1
pkgdesc="Is a python GUI application which simplifies network infrastructure penetration testing by aiding the penetration tester in the scanning and enumeration phase."
arch=('any')
@@ -11,15 +10,15 @@ url="http://sparta.secforce.com/"
license=('GPL2')
depends=('python2' 'python2-pyqt4' 'python2-elixir' 'python2-lxml')
makedeps=('nmap' 'hydra' 'cutycapt-svn' 'nikto')
-makedepends=('git')
provide=('sparta')
-source=('https://github.com/SECFORCE/sparta/archive/master.zip')
+conflicts=('sparta-git')
+source=("https://github.com/SECFORCE/sparta/archive/v${pkgver}.tar.gz")
package() {
msg2 "Installing sparta..."
install -dm755 "${pkgdir}/usr/bin/"
install -dm755 "${pkgdir}/usr/share/${pkgname}"
- cd "${srcdir}/${pkgname}-${_pkgname}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
cp -aRp --copy-contents * "${pkgdir}/usr/share/${pkgname}"
cat > $pkgdir/usr/bin/sparta << "EOF"
@@ -28,4 +27,4 @@ cd /usr/share/sparta/ && python2 sparta.py "$@"
EOF
chmod 755 "$pkgdir/usr/bin/sparta"
}
-sha256sums=('d6318d399bb41f4ac3f2c8b1ab9309ba4cbcc98a7be2448cccffb58fe47acd1c')
+sha256sums=('14aba154a94f2f31929087849c0dde44cdb59c337a8ecf2b0cecbae71690738f')