summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--[-rwxr-xr-x]PKGBUILD25
1 files changed, 10 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7d547c5e07d9..0b256473ba3d 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,21 @@
# Maintainer: FFY00 <filipe.lains@gmail.com>
# Contributor: Cyberpunk <aur_linuxero@outlook.com>
-
pkgname=sparta
pkgver=1.0.1
pkgrel=1
-pkgdesc="Is a python GUI application which simplifies network infrastructure penetration testing by aiding the penetration tester in the scanning and enumeration phase."
+pkgdesc="Python GUI application which simplifies network infrastructure penetration testing."
arch=('any')
-url="http://sparta.secforce.com/"
+url="https://sparta.secforce.com/"
license=('GPL2')
depends=('python2' 'python2-pyqt4<=4.10.0' 'python2-elixir' 'python2-lxml')
-optdepends=('cutycapt: take screenshots of websites')
-makedeps=('nmap' 'hydra' 'nikto')
-provides=('sparta')
-conflicts=('sparta')
-source=(
- "https://github.com/SECFORCE/sparta/archive/v${pkgver}.tar.gz"
- 'sparta_launcher'
-)
-md5sums=(
- '710f86f0037e735e44a3dcd01db96af6'
- '58f2181719cf57f9d5df3da9c8145c57'
-)
+optdepends=('cutycapt: take screenshots of websites'
+ 'nmap: Nmap support'
+ 'hydra: bruteforce'
+ 'nikto: information gathering')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/SECFORCE/sparta/archive/v${pkgver}.tar.gz"
+ 'sparta_launcher')
+sha256sums=('14aba154a94f2f31929087849c0dde44cdb59c337a8ecf2b0cecbae71690738f'
+ 'b4ff80756b302f76f5d20c9f92de42382d396ae29abf83e1158e18cbe493e31b')
package() {
install -dm 755 "$pkgdir"/usr/bin/