summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-x[-rw-r--r--]PKGBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 99b819ab4002..e0c8129aa502 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,29 @@
pkgname=sph-lib-git
-pkgver=350
+pkgver=650
pkgrel=1
-pkgdesc='more than 80 gpl3+ licensed guile scheme libraries'
+pkgdesc="more than 80 gpl3+ licensed guile scheme libraries"
arch=(any)
license=(gpl3+)
-makedepends=(git)
+makedepends=(gcc git)
depends=(guile)
provides=(sph-lib)
conflicts=(sph-lib)
-source=("$pkgname::git://git.sph.mn/sph-lib#branch=stable")
-url="http://sph.mn/content/187"
+source=("git://git.sph.mn/sph-lib")
+url="http://sph.mn/computer/software/sph-lib.html"
md5sums=(SKIP)
pkgver() {
- cd $pkgname
+ cd sph-lib
git rev-list --count HEAD
}
+build() {
+ cd sph-lib
+ export C_INCLUDE_PATH=/usr/include/guile/2.2/
+ ./exe/compile-c
+}
+
package() {
- cd $pkgname
+ cd sph-lib
./exe/install --prefix="${pkgdir}"
} \ No newline at end of file