summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d7b08d75bee5..20590b4a1e2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
pkgname=sph-lib-git
-_gitname=sph-lib
-pkgver=a641d33
-pkgrel=3
+pkgver=181
+pkgrel=1
pkgdesc='set of over 80 guile scheme libraries'
arch=(any)
license=(gpl3)
makedepends=(git)
depends=(guile)
provides=(sph-lib)
-source=("git://git.sph.mn/sph-lib")
+source=("$pkgname::git://git.sph.mn/sph-lib#branch=stable")
url="http://sph.mn/content/187"
md5sums=(SKIP)
pkgver() {
- cd $_gitname
- git log -n 1 --pretty=format:"%h"
+ cd $pkgname
+ git rev-list --count HEAD
}
package() {
- cd $_gitname
+ cd $pkgname
chmod 755 -R "${pkgdir}"
./exe/install "${pkgdir}"
} \ No newline at end of file