summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 501968437885..3592068e7f77 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
pkgname=sescript-git
-_gitname=sescript
-pkgver=0
+pkgver=31
pkgrel=1
pkgdesc='a scheme syntax to ecmascript and javascript compiler'
arch=(any)
-license=(GPL3)
+license=(gpl3+)
makedepends=(git)
-depends=(guile sph-lib-git)
+depends=("guile>=2" sph-lib)
provides=(sescript)
-source=("git://git.sph.mn/$_gitname")
+conflicts=(sescript)
+source=("$pkgname::git://git.sph.mn/sescript#branch=stable")
url="http://sph.mn"
md5sums=(SKIP)
pkgver() {
- cd $_gitname
- git log -n 1 --pretty=format:"%h"
+ cd $pkgname
+ git rev-list --count HEAD
}
package() {
- cd $_gitname
+ cd $pkgname
./exe/install "${pkgdir}"
- chmod 755 -R "${pkgdir}"
} \ No newline at end of file