summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..66b6fe9ed521
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgname=sescript-git
+_gitname=sescript
+pkgver=3d8cd12
+pkgrel=1
+pkgdesc='a scheme syntax to ecmascript and javascript compiler'
+arch=(any)
+license=(GPL3)
+makedepends=(git gcc)
+depends=(guile sph-lib-git)
+provides=(sescript)
+source=("git://git.sph.mn/$_gitname")
+url="http://sph.mn/content/3d3"
+md5sums=(SKIP)
+
+pkgver() {
+ cd $_gitname
+ git log -n 1 --pretty=format:"%h"
+}
+
+package() {
+ cd $_gitname
+ ./exec/install "${pkgdir}"
+ chmod 755 -R "${pkgdir}"
+} \ No newline at end of file