summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ccb8c6efe17
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Jan Houben <jan@nexttrex.de>
+# Maintainer: Jesus Alvarez <jeezusjr at gmail dot com>
+#
+# This PKGBUILD was generated by the archzfs build scripts located at
+#
+# http://github.com/minextu/archzfs/tree/linux-hardened
+#
+# ! WARNING !
+#
+# The archzfs packages are kernel modules, so these PKGBUILDS will only work with the kernel package they target. In this
+# case, the archzfs-linux-hardened packages will only work with the default linux-hardened package! To have a single PKGBUILD target
+# many kernels would make for a cluttered PKGBUILD!
+#
+# If you have a custom kernel, you will need to change things in the PKGBUILDS. If you would like to have AUR or archzfs repo
+# packages for your favorite kernel package built using the archzfs build tools, submit a request in the Issue tracker on the
+# archzfs github page.
+#
+#
+pkgname="spl-linux-hardened"
+pkgver=0.6.5.11_4.12.d.0_1
+pkgrel=1
+pkgdesc="Solaris Porting Layer kernel modules."
+depends=("spl-utils-linux-hardened" "kmod" "linux-hardened=4.12.d-1")
+makedepends=("linux-hardened-headers=4.12.d-1")
+arch=("x86_64")
+url="http://zfsonlinux.org/"
+source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.6.5.11/spl-0.6.5.11.tar.gz")
+sha256sums=("ebab87a064985f93122ad82721ca54569a5ef20dc3579f84d18075210cf316ac")
+groups=("archzfs-linux-hardened")
+license=("GPL")
+install=spl.install
+provides=("spl")
+conflicts=('spl-utils-linux' 'spl-utils-linux-git' 'spl-utils-linux-lts' 'spl-utils-linux-lts-git' 'spl-linux-hardened-git')
+
+build() {
+ cd "${srcdir}/spl-0.6.5.11"
+ ./autogen.sh
+ ./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin \
+ --with-linux=/usr/lib/modules/4.12.0-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.12.0-1-hardened/build \
+ --with-config=kernel
+ make
+}
+
+package() {
+ cd "${srcdir}/spl-0.6.5.11"
+ make DESTDIR="${pkgdir}" install
+ mv "${pkgdir}/lib" "${pkgdir}/usr/"
+ # Remove reference to ${srcdir}
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.12.0-1-hardened/Module.symvers
+}