summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 29 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 29581dddec42..6c459c90abf4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,39 @@
-# Maintainer: Sibren Vasse <arch at sibrenvasse dot nl>
+# Maintainer: Tab Fitts <tfitts [at] spryservers [dot] net>
# Contributor: oguzkagan <me at oguzkaganeren dot com dot tr>
+# Contributor: Sibren Vasse <arch at sibrenvasse dot nl>
#
pkgname=splashtop-streamer
-pkgver=2.6.2.0
+pkgver=3.0.4.0
pkgrel=1
pkgdesc="Splashtop Remote Streamer. Remotely access your desktop from any device from anywhere!"
arch=('x86_64')
-url="http://www.splashtop.com/streamer/linux"
-license=('custom')
-depends=('apr>=1.5.2' 'apr-util>=1.5.4' 'bash-completion>=2.7.3' 'curl>=7.47.0' 'dbus>=1.9.14' 'dbus-glib>=0.78' 'glib2>=2.12.0' 'libcurl-gnutls>=7.16.2' 'libpulse>=0.99.1' 'libutil-linux>=2.16' 'libx11' 'libxfixes' 'libxrandr>=1.2.0' 'libxtst' 'mumble' 'networkmanager' 'pam>=0.99.7.1' 'python>=2.6.1' 'python2-libappindicator')
+url="https://www.splashtop.com"
+license=('Proprietary')
+groups=('')
+depends=('bash-completion' 'cairo>=1.2.4' 'curl>=7.47.0' 'dbus' 'dbus-glib' 'desktop-file-utils' 'gcc>=3.0' 'gdk-pixbuf2' 'glib2>=2.43.2' 'gtk3>=3.5.12' 'hicolor-icon-theme' 'libappindicator-gtk3>=0.2.92' 'libnotify>=0.7.0' 'libproxy>=0.4.11' 'libpulse>=0.99.1' 'libxcb>=1.3' 'lshw' 'pam>=0.99.7.1' 'systemd-libs>=217' 'uriparser>=0.6.0' 'util-linux-libs>=2.16' 'xcb-util>=0.4.0' 'xcb-util-keysyms>=0.4.0' 'zlib>=1.2.0' 'binutils' 'libxrandr' 'libxfixes' 'libxtst')
+provides=('splashtop-streamer')
+backup=('etc/dbus-1/system.d/com.splashtop.streamer.Daemon.conf')
+options=('!strip' '!emptydirs')
install=${pkgname}.install
-makedepends=('curl' 'p7zip')
-source=(https://d17kmd0va0f0mp.cloudfront.net/linux/Splashtop_Streamer_Ubuntu_v${pkgver//_/-}_amd64.tar.gz)
-sha256sums=('6d5f6d6613e3fee39af692c35228716002894c9e9f4cc4257c360e9b0e00f68e')
+source=("https://download.splashtop.com/linux/STB_CSRS_Ubuntu_v${pkgver}_amd64.tar.gz")
+sha512sums=('15cca0bb9d1562d67da4dbd6a8c1a369919d77e4e132beb10f7af32e33e3b794c2fc11d664562a6872d8af8a6908a0814656baae68bcc0ca2d60383d499b9527')
-package ()
-{
- msg "Extracting Splashtop package"
- #cd "$srcdir/$pkgname-$pkgver"
- tar -xf $srcdir/data.tar.xz -C $pkgdir
- sed -i 's/python /python2 /' $pkgdir/opt/splashtop-streamer/script/spt_main
- install -D -m644 "$pkgdir/opt/splashtop-streamer/EULA.htm" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+prepare(){
+ tar xzf STB_CSRS_Ubuntu_v${pkgver}_amd64.tar.gz
+ ar -x Splashtop_Streamer_Ubuntu_amd64.deb
}
-# vim:set ts=2 sw=2 et:
+package(){
+
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
+
+ # Fix directory structure differences
+ cd "${pkgdir}"
+
+ install -D -m644 "${pkgdir}/opt/splashtop-streamer/EULA.htm" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ mkdir -p usr/lib 2> /dev/null; mv lib/* usr/lib; rm -rf lib
+
+ cd ..
+
+}