summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 8 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5a85562a64ea..767dfd13e0a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=spotdl
pkgver=4.2.5
-pkgrel=1
+pkgrel=4
pkgdesc='Download your Spotify playlists and songs along with album art and metadata (from YouTube if a match is found).'
arch=('any')
@@ -43,31 +43,27 @@ depends=(
)
makedepends=('python-build' 'python-installer' 'python-wheel' 'python-poetry-core')
checkdepends=('python-pytest-asyncio' 'python-pytest-mock')
-provides=("$pkgname" 'python-spotdl')
+provides=('python-spotdl')
replaces=('python-spotdl')
conflicts=('python-spotdl')
-# source=("https://github.com/spotDL/spotify-downloader/archive/refs/tags/v$pkgver.zip")
-source=("https://files.pythonhosted.org/packages/source/s/$pkgname/$pkgname-$pkgver.tar.gz")
-b2sums=('e7b1ba0c7bebceb0d78ea0b4974b7a2a46612f03a3b3e457f8f996d68b9b23df0c199448956ad5f4398effbe5d59d51c43c310f998a8d4798d07bb89f6c51a5d')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+b2sums=('cb45720745936cb4e14fb121e34871614e5be4bdc10f0c23058f979dfd788dd7da06ceb3cc633c93fb7bf799080256f718e29f8ff30fba275be9c6c3f9eae2ca')
# Document: https://wiki.archlinux.org/title/Python_package_guidelines
build() {
- # cd spotify-downloader-$pkgver
- cd spotdl-$pkgver
+ cd spotify-downloader-$pkgver
# https://github.com/python-poetry/poetry/issues/5547
python -m build --wheel --no-isolation
}
check() {
- # cd spotify-downloader-$pkgver
- cd spotdl-$pkgver
- pytest || echo 'Tests failed! OR no tests.'
+ cd spotify-downloader-$pkgver
+ pytest || echo 'Tests failed!'
}
package() {
- # cd spotify-downloader-$pkgver
- cd spotdl-$pkgver
+ cd spotify-downloader-$pkgver
python -m installer --destdir="$pkgdir" dist/*.whl
install -vDm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}