summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 2 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d6b8dc7d6ce..d96905f51e5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,18 @@
##
-# Maintainer: pyamsoft <pyam(dot)soft(at)gmail(dot)com>
+# Maintainer: psamim <psamim(at)gmail(dot)com>
##
_gitname=spotify-dl
-# shellcheck disable=SC2034
pkgname=spotify-dl-git
-# shellcheck disable=SC2034
-pkgdesc="Script that allows you to download Spotify songs or playlists"
-# shellcheck disable=SC2034
+pkgdesc="Script that allows you to download Spotify songs or playlists from Youtube"
pkgver=r9.97bdc5c
-# shellcheck disable=SC2034
pkgrel=1
-# shellcheck disable=SC2034
arch=('any')
-# shellcheck disable=SC2034
makedepends=('git')
-# shellcheck disable=SC2034
depends=('python2-beautifulsoup4' 'youtube-dl')
-# shellcheck disable=SC2034
optdepends=()
-# shellcheck disable=SC2034
provides=('spotify-dl')
-# shellcheck disable=SC2034
conflicts=('spotify-dl')
-# shellcheck disable=SC2034
license=('GPL3')
url="https://github.com/invicnaper/spotify-dl"
@@ -31,14 +20,10 @@ url="https://github.com/invicnaper/spotify-dl"
# The SHA256 is constantly changing since this is
# pulled from git so skip the verification check
##
-# shellcheck disable=SC2034
-# shellcheck disable=SC2034
source=("${_gitname}::git+${url}#branch=master" "01-change-hashbang.patch")
sha256sums=('SKIP'
'34b8600fd2c39707ab481373e9feee8a7f0acd3ac06cad64966224fe276f44c4')
-###############################################################################
-
pkgver() {
# shellcheck disable=SC2154
cd "$srcdir/$_gitname" || {
@@ -52,7 +37,6 @@ pkgver() {
}
prepare() {
- # shellcheck disable=SC2154
cd "$srcdir/$_gitname" || {
msg "Could not cd into $srcdir/$_gitname"
return 1
@@ -63,13 +47,11 @@ prepare() {
}
package() {
- # shellcheck disable=SC2154
cd "$srcdir/$_gitname" || {
msg "Could not cd into $srcdir/$_gitname"
return 1
}
- # shellcheck disable=SC2154
install -Dm 755 "spotify-dl.py" "${pkgdir}/usr/bin/${_gitname}"
install -Dm 644 "GPLv3.txt" "${pkgdir}/usr/share/doc/${_gitname}/LICENSE"
install -Dm 644 "README.md" "${pkgdir}/usr/share/doc/${_gitname}/README"