summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 48c13f5bc67c..6c9cf6b548ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,16 @@
-# Maintainer: bluemeda <affif[dot]bluemeda[at]gmail[dot]com>
_name=spotify-ripper
pkgname=spotify-ripper
-pkgver=2.9.1
+pkgver=2.11
pkgrel=1
-pkgdesc='a small ripper for Spotify that rips Spotify URIs to audio files'
+pkgdesc='Command-line ripper for Spotify, with a workaround for playlist emptying'
arch=('any')
-url="https://github.com/jrnewell/$_name"
+url="https://github.com/SolidHal/$_name"
license=('MIT')
-depends=('python2' 'python2-pyspotify=2.0.5' 'python2-colorama-0.3.3' 'python2-mutagen-1.30' 'python2-requests>=2.3.0' 'python2-schedule>=0.3.1' 'lame')
+depends=('python2' 'python2-pyspotify=2.0.5' 'python2-colorama-0.3.3' 'python2-mutagen-1.30' 'python2-requests>=2.3.0' 'python2-schedule>=0.3.1' 'python2-spotipy' 'lame')
optdepends=('flac: Rip songs to lossless FLAC encoding' 'opus-tools: Rip songs to Opus encoding' 'vorbis-tools: Rip songs to Ogg Vorbis encoding' 'faac: Rip songs to AAC format with FreeAAC' 'libav-git-no-libs: Rip songs to Apple Lossless format' 'fdkaac: Rip songs to MP4/M4A format with Fraunhofer FDK AAC codec')
makedepends=('python2-setuptools')
-source=("https://github.com/jrnewell/spotify-ripper/archive/"$pkgver".zip")
-md5sums=('b88f7a7336c67da7428672d94ee24827')
+source=("https://github.com/SolidHal/spotify-ripper/archive/"$pkgver".zip")
+md5sums=('9e15172c41c80eb46b149a3799f9e66a')
package() {
cd "$srcdir/$_name-$pkgver"