summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4155c7d0b0df..fe5477f9ebe2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgdesc='Command-line ripper for Spotify, with a workaround for playlist emptyin
arch=('any')
url="https://github.com/hbashton/spotify-ripper"
license=('MIT')
-depends=('python2' 'python2-pyspotify=2.0.5' 'python2-colorama-0.3.3' 'python2-mutagen-1.30' 'python2-requests>=2.3.0' 'python2-schedule>=0.3.1')
+depends=('python2' 'python2-pyspotify=2.0.5' 'python2-colorama-0.3.3' 'python2-mutagen' 'python2-requests>=2.3.0' 'python2-schedule>=0.3.1')
optdepends=('lame: Rip songs to mp3' 'flac: Rip songs to lossless FLAC encoding' 'opus-tools: Rip songs to Opus encoding' 'vorbis-tools: Rip songs to Ogg Vorbis encoding' 'faac: Rip songs to AAC format with FreeAAC' 'libav-git-no-libs: Rip songs to Apple Lossless format' 'fdkaac: Rip songs to MP4/M4A format with Fraunhofer FDK AAC codec')
makedepends=('python2-setuptools' 'git')
source=("git+https://github.com/hbashton/spotify-ripper")
@@ -22,5 +22,7 @@ pkgver() {
package() {
cd "$_name"
+ ls
+ sed -i 's/mutagen==/mutagen>=/' setup.py
python2 setup.py install --root="$pkgdir"
}