summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 18 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5b0e760b9d00..fc21735a7e69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,39 @@
-# Maintainer: Shengyu Zhang <arch at srain.im>
+# Maintainer: Shengyu Zhang <la@archlinuxcn.org>
pkgname=srain
-pkgver=0.06.4
+pkgver=1.0.0rc2
pkgrel=1
-pkgdesc="Modern, beautiful IRC client written in GTK+ 3"
+pkgdesc="Modern IRC client, git version"
arch=('i686' 'x86_64')
license=('GPL')
url="https://srain.im"
-depends=('gtk3' 'python' 'curl' 'libnotify' 'libconfig' 'libsoup')
-makedepends=('git' 'make' 'gcc' 'pkg-config' 'gettext' 'imagemagick')
+makedepends=('git' 'make' 'gcc' 'pkg-config' 'gettext' 'python-sphinx')
+depends=('glib2' 'gtk3' 'libconfig' 'libsoup')
optdepends=(
'glib-networking: TLS connection support'
- 'python-sphinx: for generating documentation'
- 'python-urllib3: avatar and pastebin support'
- 'python-requests: avatar and pastebin support'
)
-conflicts=('srain-git')
+conflicts=('srain')
provides=('srain')
-source=("https://github.com/SilverRainZ/${pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('f8449f1144fadfeb62095afffa62b4129717296b07baf2d8da5a290e9d29eca2')
+source=("https://github.com/SrainApp/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('39782f044ab7b780c84cfa61c93f3617bdcb7506a74a67dea186d3d0356229a7')
+
+_prefix='/usr'
build() {
cd ${pkgname}-${pkgver}
- ./configure --prefix=/usr --config-dir=/etc --disable-debug
+ ./configure \
+ --prefix="${_prefix}" \
+ --datadir="${_prefix}/share" \
+ --sysconfdir="/etc" \
+ --disable-debug
make
+ make doc
}
package() {
cd ${pkgname}-${pkgver}
- make DESTDIR=$pkgdir install
+ make DESTDIR="${pkgdir}" install
+ make DESTDIR="${pkgdir}" install-doc
}