summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bfbf234e181a..d8844897b02c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,21 @@
# Maintainer: spider-mario <spidermario@free.fr>
pkgname=ssimulacra
-pkgver=0.1
-pkgrel=2
+pkgver=0.2
+pkgrel=3
pkgdesc="Structural SIMilarity Unveiling Local And Compression Related Artifacts"
arch=('x86_64')
url="https://github.com/cloudinary/ssimulacra"
license=('Apache')
-depends=('opencv2')
-makedepends=('vtk')
-source=('git+https://github.com/cloudinary/ssimulacra.git#commit=589fac281aa4a8ecfb9ce07ec2e6f6dd1e6eccbb')
-sha512sums=('SKIP')
+depends=('opencv')
+makedepends=('boost' 'git')
+source=('git+https://github.com/cloudinary/ssimulacra.git#commit=375726b13f9dec2a01950e6710e7e9f488c52ea3'
+ 'opencv4.patch')
+sha512sums=('SKIP'
+ '3d08d467c71b1bb64ad232a530fb970467c76ac745d7bd75f6df3c8823bf9a54448b98287098cec6076e80093b745b9f26e085048ed49afe7998c0254de3c77b')
prepare() {
cd "$pkgname"
- perl -pe 's/(?:C|LD)FLAGS\K=/+=/g' -i Makefile
+ git apply --3way "$srcdir"/opencv4.patch
}
build() {