summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 7 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f0adbf43efa9..f6bf5361ceb9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,17 @@
# Maintainer: Xuanrui Qi <me@xuanruiqi.com>
pkgname=ssrmint-git
-pkgver=r13.fa1f7ab
-pkgrel=5
+pkgver=r19.658e636
+pkgrel=6
pkgdesc="Ad-hoc pygments style and lexer for LaTeX pretty-printing of SSReflect"
arch=('any')
url="https://github.com/affeldt-aist/ssrmint"
license=('BSD')
depends=('python' 'python-pygments')
-makedepends=('git' 'python-setuptools')
+makedepends=('git' 'python-build' 'python-installer' 'python-wheel')
optdepends=()
conflicts=()
-source=("$pkgname::git+https://github.com/affeldt-aist/ssrmint"
- "license.patch")
-sha256sums=('SKIP'
- '6fa40b2b50c0cd2e513b2b9438a6d41e466a6012e7ac6d97f5ec578d44dfef5c')
+source=("$pkgname::git+https://github.com/affeldt-aist/ssrmint")
+sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
@@ -22,13 +20,12 @@ pkgver() {
build() {
cd "$srcdir/$pkgname"
- patch -p1 < ../license.patch
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$srcdir/$pkgname"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm744 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
}