summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8b31675e9f5e..77c177239b51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Shell Chen <aur@sorz.org>
pkgname=sstp-server
-pkgver=0.4.2
+pkgver=0.5.0
pkgrel=1
pkgdesc="A Secure Socket Tunneling Protocol (SSTP) server."
url="https://github.com/sorz/sstp-server"
license=('MIT')
arch=('x86_64' 'i686')
backup=('etc/sstp-server.ini')
-depends=('python2>=2.7' 'python2-twisted' 'python2-service-identity' 'python2-argparse'
- 'python2-ipaddress' 'ppp')
-makedepends=('python2-setuptools')
+depends=('python>=3.5' 'ppp')
+optdepends=('python-uvloop: better performance')
+makedepends=('python-setuptools')
source=("https://github.com/sorz/sstp-server/archive/v$pkgver.tar.gz"
"sstp-server@.service")
-sha256sums=('e715c1e3252c94a34b9d8a4bc2c817f192aae6df36969c1af73b211b4be53067'
- '15cd7335939668d7f8487574ae457192257550ceadf50fb74393536997a42c10')
+sha256sums=('d7e24c07669a8375abc7efc469dd39e308a55c608a8fb0665255dec37045aff2'
+ '197ad957e7987ca9e828bab9d4322c8d2bfb9edcc0ecab1ef23470a1e1aae1a6')
build() {
cd "$srcdir/$pkgname-$pkgver"