summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fc9cf60da50d..b68e76f13b11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,6 +32,12 @@ prepare() {
-e '/char worddelimiters/s/= .*/= " '"'"'`\\\"()[]{}<>|";/' \
-e '/int defaultcs/s/= .*/= 1;/' \
-i config.def.h
+ sed \
+ -e 's/CPPFLAGS =/CPPFLAGS +=/g' \
+ -e 's/CFLAGS =/CFLAGS +=/g' \
+ -e 's/LDFLAGS =/LDFLAGS +=/g' \
+ -e 's/_BSD_SOURCE/_DEFAULT_SOURCE/' \
+ -i config.mk
sed '/@tic/d' -i Makefile
}