summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 489a51b6ef4f..bc8d269f6b64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,11 +23,14 @@ makedepends=(
)
conflicts=("${_name}")
provides=("${_name}")
-source=("${_name}::git+${url}")
+source=("${_name}::git+${url}"
+ "git+https://github.com/ggerganov/ggml.git")
prepare() {
cd "${srcdir}/${_name}"
- git submodule update --init
+ git submodule init
+ git config submodule.ggml.url "${srcdir}/ggml"
+ git -c protocol.file.allow=always submodule update
if [ ! -d "${srcdir}/${_name}-cublas" ]; then
cp -r "${srcdir}/${_name}" "${srcdir}/${_name}-cublas"
@@ -120,4 +123,5 @@ package_stable-diffusion.cpp-hipblas-git() {
DESTDIR="${pkgdir}" cmake --install build
}
-sha256sums=('SKIP')
+sha256sums=('SKIP'
+ 'SKIP')