summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c866806006b1..88fc509cecb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_arch=$(uname -m)
pkgname=stack-static
pkgver=2.1.3
-pkgrel=1
+pkgrel=2
pkgdesc="The Haskell Tool Stack (linked statically)"
arch=('x86_64')
url="https://github.com/commercialhaskell/stack"
@@ -12,7 +12,10 @@ provides=( stack )
conflicts=( stack stack-bin haskell-stack )
replaces=( stack stack-bin haskell-stack )
depends=( gmp gcc-libs zlib ncurses5-compat-libs ) # needed for working ghc downloaded by stack
-optdepends=( bash-completion )
+optdepends=(
+ 'bash-completion'
+ "ncurses5-compat-libs: using older ghc's linking against libtinfo.so.5"
+)
source=(
"stack.bash"
"https://github.com/commercialhaskell/stack/releases/download/v${pkgver}/stack-${pkgver}-linux-x86_64-static.tar.gz"