summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2a6e96084180..066bf39d4d5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=standardese-git
pkgver=0.5.2.r9.gefbc112
-pkgrel=3
+pkgrel=4
pkgdesc="A (work-in-progress) nextgen Doxygen for C++"
arch=('i686' 'x86_64')
url="https://github.com/foonathan/standardese"
@@ -19,6 +19,12 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ # Set to statically link dependencies
+ sed -i "/option(BUILD_SHARED_LIBS/d" "CMakeLists.txt"
+}
+
build() {
cd "$srcdir/${pkgname%-git}"
rm -rf build