summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6ecf45ba09a3..0166bee5e3c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgrel=1
pkgdesc="Story Architect is a text editor for film, theatre, radio scripts or comic books."
arch=('x86_64')
url='https://starc.app/'
-license=('GPL3')
+license=('GPL3' 'custom')
depends=('zlib' 'bash')
provides=("${_name}=${pkgver}")
conflicts=("${_name}")
@@ -28,9 +28,14 @@ prepare() {
}
package() {
+ # Install AppImage and bin
install -Dm755 "${srcdir}/${_filename}" "${pkgdir}/opt/appimages/${_name}.AppImage"
install -Dm755 "${srcdir}/${_name}.sh" "${pkgdir}/usr/bin/${_name}"
+ # Install icon and desktop
install -Dm644 "${srcdir}/squashfs-root/${_name}.png" "${pkgdir}/usr/share/pixmaps/${_name}.png"
install -Dm644 "${srcdir}/squashfs-root/${_name}.desktop" "${pkgdir}/usr/share/applications/${_name}.desktop"
+
+ # TODO: Install custom LICENSE when author makes it
+ # install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}