summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 17 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 541f9cdd39fc..b9cc8a0958b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,33 @@
-# Maintainer: Acidhub <dev@acidhub.click>
+# Maintainer: Lara <dev@lara.monster
+# Contributor: Felix Golatofski <contact@xdfr.de>
+# Contributor: Acidhub <dev@acidhub.click>
pkgname=steam-tools-ng
-pkgver=0.9.3
+pkgver=3.1.4
pkgrel=1
-pkgdesc="Some useful tools for use with Steam client and some steam related websites."
+pkgdesc="Some useful tools for use with steam client or compatible programs, websites"
arch=('any')
-url="https://github.com/ShyPixie/steam-tools-ng"
-depends=('python>=3.7' 'python-certifi' 'python-aiohttp' 'python-gobject' 'stlib>=0.12.1' 'stlib-plugins-git')
-makedepends=('python-setuptools')
+url="https://github.com/calendulish/steam-tools-ng"
+depends=('python>=3.9' 'python-certifi' 'python-aiohttp' 'python-stlib>=2.0' 'python-stlib-plugins>=1.2.3' 'python-gobject' 'gtk4')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'imagemagick')
license=('GPL')
-source=("https://github.com/ShyPixie/$pkgname/archive/v${pkgver}.tar.gz")
-sha256sums=('dab78db4d31aa7453274fc8f3d1a7e46e40a39f68523f6bbbad0055ea6fbc8bb')
+source=(
+ "https://github.com/calendulish/$pkgname/archive/v${pkgver}.tar.gz"
+)
+sha256sums=('3a24a4a0e8dc2fe8587a950246067ccc03a611c94e534475cd228f952490f779')
build() {
cd $pkgname-$pkgver
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd $pkgname-$pkgver
- python setup.py install --skip-build --optimize=1 --root=$pkgdir
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ sed -i "s|^Icon=.*|Icon=steam-tools-ng|g" steam-tools-ng.desktop
install -Dm644 steam-tools-ng.desktop $pkgdir/usr/share/applications/steam-tools-ng.desktop
- cp -rf icons/* $pkgdir/usr/share/steam-tools-ng/icons/
+ convert -resize 512x512 src/steam_tools_ng/icons/stng.png steam-tools-ng.png
+ install -Dm644 steam-tools-ng.png -t "$pkgdir"/usr/share/icons/hicolor/512x512/apps
}