summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a61e6282f5f5..b81c2135630b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,24 @@
pkgname=steam-tools-ng
pkgver=3.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Some useful tools for use with steam client or compatible programs, websites"
arch=('any')
url="https://github.com/calendulish/steam-tools-ng"
depends=('python>=3.9' 'python-certifi' 'python-aiohttp' 'python-stlib>=1.3' 'python-stlib-plugins>=1.2' 'python-gobject' 'gtk4')
makedepends=('python-build' 'python-installer' 'python-wheel' 'imagemagick')
license=('GPL')
-source=("https://github.com/calendulish/$pkgname/archive/v${pkgver}.tar.gz")
-sha256sums=('c0fa03ec0e9d29aa35efce30fee65fa49e9dd6ae0bda2d289dd96171afca5b01')
+source=(
+ "https://github.com/calendulish/$pkgname/archive/v${pkgver}.tar.gz"
+ "steam-tools-ng-3.0.1-pygobject-fix.patch"
+)
+sha256sums=('c0fa03ec0e9d29aa35efce30fee65fa49e9dd6ae0bda2d289dd96171afca5b01'
+ '4817bc7b0e816fa3789f9c960b3351affd73148b839fffaa63ca0537558100f3')
+
+prepare() {
+ cd $pkgname-$pkgver
+ patch -Np1 < "../steam-tools-ng-3.0.1-pygobject-fix.patch"
+}
build() {
cd $pkgname-$pkgver