summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 588735373012..10923496d9fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
# Contributor: Acidhub <dev@acidhub.click>
pkgname=steam-tools-ng
-pkgver=0.9.4
+pkgver=1.0.3
pkgrel=1
pkgdesc="Some useful tools for use with Steam client and some steam related websites."
arch=('any')
url="https://github.com/ShyPixie/steam-tools-ng"
depends=('python>=3.7' 'python-certifi' 'python-aiohttp' 'python-gobject' 'stlib>=0.12.1' 'stlib-plugins-git')
-makedepends=('python-setuptools')
+makedepends=('python-setuptools' 'imagemagick')
license=('GPL')
source=("https://github.com/ShyPixie/$pkgname/archive/v${pkgver}.tar.gz")
-sha256sums=('fc1dd71f0cf764f734a5b2aaff7c5483e280c2b1a0fe944d8e3130df96f854df')
+sha256sums=('663c0a0a013856b21a1f45d7141280591d0990c9573ac6d1afbd497ea42364a5')
build() {
cd $pkgname-$pkgver
@@ -21,8 +21,11 @@ build() {
package() {
cd $pkgname-$pkgver
python setup.py install --skip-build --optimize=1 --root=$pkgdir
+ sed -i "s|^Icon=.*|Icon=stng|g" steam-tools-ng.desktop
install -Dm644 steam-tools-ng.desktop $pkgdir/usr/share/applications/steam-tools-ng.desktop
- cp -rf icons/* $pkgdir/usr/share/steam-tools-ng/icons/
+ cd build/lib/steam_tools_ng/icons/
+ convert -resize 512x512 stng.png stng.png
+ install -Dm644 stng.png -t $pkgdir/usr/share/icons/hicolor/512x512/apps
}