summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 23 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e74a76ab4f1f..4241ecf46544 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,27 +4,34 @@
pkgname=steamtinkerlaunch-git
pkgver=4.0_next7.r194.145caa2
-pkgrel=1
+pkgrel=2
pkgdesc="Wrapper script for Steam custom launch options"
arch=('any')
url="https://github.com/frostworx/steamtinkerlaunch"
license=('GPL3')
-depends=('bash')
+depends=('bc' 'bash' 'procps-ng' 'unzip' 'wget' 'which' 'xdotool' 'xorg-xprop' 'xorg-xrandr' 'xorg-xwininfo' 'yad')
makedepends=('git')
optdepends=(
- 'strace'
- 'zenity'
- 'gamemode'
- 'mangohud'
- 'vkbasalt'
- 'winetricks'
- 'wget: for optional reshade download'
- 'unzip: for optional reshade download'
- 'git: for pulling optional shaders'
- 'xdotool: for playing regular games side-by-side in VR'
- 'xorg-xwininfo: for playing regular games side-by-side in VR'
- 'vr-video-player: for playing regular games side-by-side in VR'
- 'xdg-utils: for opening the ProtonDB URL of started game'
+ 'strace: write a strace log of the launched game'
+ 'gamemode: for using GameMode per game'
+ 'mangohud: for using MangoHUD per game'
+ 'vkbasalt: for using vkBasalt per game'
+ 'winetricks: winetricks support'
+ 'vr-video-player: for playing regular games side-by-side in VR'
+ 'nyrna: for using Nyrna per game'
+ 'replay-sorcery: for using Replay-Sorcery per game'
+ 'net-tools: for optional network monitoring'
+ 'boxtron: for optional Boxtron support'
+ 'scummvm: for optional ScummVM support via Roberta'
+ 'wine: for optional Vortex Mod Manager support'
+ 'gameconqueror: for optional cheating'
+ 'gamescope: for optional GameScope support'
+ 'libnotify: for optional Notifier'
+ 'cabextract: optional for extracting the wmp10 setup archive'
+ 'innoextract: optional for extracting the Cheat Engine setup archive'
+ 'usbutils: optional for a quick VR HMD presence check'
+ 'jq: optional for extracting game names from the steam api and for sorting available Lutris Wine Versions'
+ 'rsync: optional for backing up steamuser files from proton games'
)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -46,4 +53,4 @@ package() {
cp -r categories lang misc regs reshadepresets tweaks "$pkgdir/usr/share/stl"
install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
-} \ No newline at end of file
+}