summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e6ee1cb775ab..2d091b6e2a5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# https://github.com/orhun/pkgbuilds
pkgname=stegano-git
-pkgver=0.4.1.r0.g5774494
-pkgrel=2
+pkgver=0.4.1.r8.g46fd3fd
+pkgrel=1
pkgdesc="CLI tool for steganography. Supports hiding data in PNG images via LSB Encoding. (git)"
arch=('x86_64')
url="https://github.com/steganogram/stegano-rs"
@@ -24,6 +24,11 @@ build() {
cargo build --release --locked
}
+check() {
+ cd "${pkgname%-git}-rs/${pkgname%-git}-cli"
+ cargo test --release --locked
+}
+
package() {
cd "${pkgname%-git}-rs"
install -Dm 755 "target/release/${pkgname%-git}" -t "${pkgdir}/usr/bin"