summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 25 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f844500ce2d6..8dacc384d801 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Marco Pompili
+# Maintainer: Marco Pompili [ marcs (dot) pompili (at) gmail (dot) com ]
# Contributor: Lukas Fleischer <lfleischer@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
# Contributor: Jason Chu <jason@archlinux.org>
@@ -6,39 +6,45 @@
pkgname=steghide
pkgver=0.5.1
-pkgrel=9
+pkgrel=11
pkgdesc='Embeds a message in a file by replacing some of the least significant bits'
arch=('x86_64')
url='http://steghide.sourceforge.net'
license=('GPL')
depends=('libmcrypt' 'gcc-libs' 'mhash' 'libjpeg' 'zlib')
-source=("https://iweb.dl.sourceforge.net/project/steghide/steghide/${pkgver}/steghide-${pkgver}.tar.gz"
- 'buildsystem.patch'
- 'gcc-4.2.patch'
- "${pkgname}-climits.patch"
- steghide-gcc6.patch)
-md5sums=('5be490e24807d921045780fd8cc446b3'
- '14f5e054d71c91262bb1140288043df8'
- 'fd861dc5a0a392c6c94a61e85ad74f29'
- '897ce18edd008293a3328bc3f88775b3'
- '6dd60a84fccca270fa7315f1102454ff')
+source=("steghide-${pkgver}.tar.gz::https://sourceforge.net/projects/steghide/files/steghide/${pkgver}/steghide-${pkgver}.tar.gz/download"
+ buildsystem.patch
+ include-climits.patch
+ add-hardening.patch
+ fix-spelling.patch
+ consolidated-gcc-patches.patch
+ correct-german.patch)
+sha256sums=('78069b7cfe9d1f5348ae43f918f06f91d783c2b3ff25af021e6a312cf541b47b'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ msg2 "Applying fixes patches"
patch -p1 < ../buildsystem.patch
+ patch -p1 -i ../include-climits.patch
- # this patch courtesy gentoo bug tracker #178134
- patch -Np1 -i ../gcc-4.2.patch
- patch -Np1 -i ../steghide-climits.patch
-
- patch -p1 -i ../steghide-gcc6.patch # Fix build with GCC 6
+ msg2 "Apply patches from Debian"
+ patch -Np1 -i ../add-hardening.patch
+ patch -Np1 -i ../fix-spelling.patch
+ patch -Np1 -i ../consolidated-gcc-patches.patch
+ patch -Np1 -i ../correct-german.patch
# touch files needed by GNU Autotools
touch NEWS AUTHORS ChangeLog
+
+ ./configure --prefix=/usr --mandir=/usr/share/man
- autoreconf -i
- ./configure --prefix=/usr
make
}