summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 42216ecd694d..a667c92ee5e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,15 +5,24 @@
pkgname=stgit
pkgver=0.18
-pkgrel=1
+pkgrel=2
pkgdesc="Pushing/popping patches to/from a stack on top of Git, similar to Quilt"
url="http://www.procode.org/stgit/"
arch=('any')
license=('GPL')
depends=('python2' 'git')
makedepends=('xmlto' 'asciidoc')
-source=("https://github.com/ctmarinas/stgit/archive/v${pkgver}.tar.gz")
-sha256sums=('00c83a0a057ee61a300f2291b8926f85521ffd1c92b4cb5152e2be3bf836d3a5')
+source=(
+ "https://github.com/ctmarinas/stgit/archive/v${pkgver}.tar.gz"
+ "stgit-0.16-tmpl.patch"
+)
+sha256sums=('00c83a0a057ee61a300f2291b8926f85521ffd1c92b4cb5152e2be3bf836d3a5'
+ '98b8347845ee3d1dd15243608cab3c5d9e76caf0da0a5fa59020854450cd340c')
+
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+ patch -Np1 -i "$srcdir"/stgit-0.16-tmpl.patch
+}
build() {
cd "$srcdir"/$pkgname-$pkgver