summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cdf40e0305fb..793376a5caef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=stig-git
pkgver=0.11.2a0.r0.7ab3df0c
-pkgrel=1
+pkgrel=2
pkgdesc='TUI and CLI client for the Transmission daemon'
url='https://github.com/rndusr/stig'
depends=('python' 'python-urwid' 'python-urwidtrees' 'python-aiohttp'
- 'python-pyxdg' 'python-blinker' 'python-natsort')
+ 'python-pyxdg' 'python-blinker' 'python-natsort')
makedepends=('git' 'python-setuptools')
optdepends=('python-pprofile: profiling'
- 'python-setproctitle: prettifies the process name')
+ 'python-setproctitle: prettifies the process name')
license=('GPL')
arch=('any')
provides=('stig')
@@ -20,21 +20,22 @@ source=("git+https://github.com/rndusr/stig.git")
sha256sums=('SKIP')
pkgver() {
- cd stig
- printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g;s/^v//')"
+ cd stig
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g;s/^v//')"
}
prepare(){
- cd stig
- sed -i 's/urwidtrees>=1.0.3dev0/urwidtrees>=1.0.2/' setup.py
+ cd stig
+ sed -i 's/urwidtrees>=1.0.3dev0/urwidtrees>=1.0.2/' setup.py
+ rm .python-version
}
build() {
- cd stig
- python setup.py build
+ cd stig
+ python setup.py build
}
package() {
- cd stig
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ cd stig
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}