summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5d9d8120021b..5b8f41db9f96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,21 @@
pkgbase=('stig-git')
pkgname=('stig-git')
-pkgver=0.7.0a.r0.b0d20e3
+pkgver=0.7.3a.r524.b763aca
pkgrel=1
pkgdesc='TUI and CLI client for the Transmission daemon'
url='https://github.com/rndusr/stig'
depends=('python' 'python-urwid' 'python-urwidtrees-git' 'python-aiohttp'
- 'python-appdirs' 'python-blinker' 'python-natsort')
+ 'python-xdg' 'python-blinker' 'python-natsort')
makedepends=('git' 'python-setuptools')
optdepends=('python-geoip: shows country codes in peer lists')
license=('GPL')
arch=('any')
provides=('stig')
conflicts=('stig')
-source=("git+https://github.com/rndusr/stig.git#branch=dev")
-sha256sums=('SKIP')
+source=("git+https://github.com/rndusr/stig.git#branch=dev" "fix_xdg_dep_on_arch.patch")
+sha256sums=('SKIP'
+ '274f56f53c8eeb582c26dba53cf01cd8a91bec88d24f80a9fc72c423064fb479')
pkgver() {
cd stig
@@ -24,6 +25,7 @@ pkgver() {
build() {
cd stig
+ patch -p1 -i "${srcdir}/fix_xdg_dep_on_arch.patch"
python setup.py build
}