summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 15 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4556a43c4fc2..898a50c835f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=stm32cubemonitor
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="graphical software for helping debug and diagnose STM32 applications while they are running by reading and displaying their variables in real-time"
arch=('x86_64')
url="https://my.st.com/content/my_st_com/en/products/development-tools/software-development-tools/stm32-software-development-tools/stm32-performance-and-debuggers/stm32cubemonitor.html"
@@ -11,9 +11,22 @@ depends=('gtk3' 'nodejs' 'nss' 'libxss' 'libnotify' 'libxtst' 'xdg-utils' 'at-sp
provides=("${pkgname}-bin")
conflicts=("${pkgname}-bin")
options=('!strip')
-source=('local://en.STM32CubeMonitor_lin.zip')
+_pkg_file_name=en.STM32CubeMonitor_lin.zip
+source=("local://${_pkg_file_name}")
sha256sums=('d82c5282b8d3f64c68b58426bacd1b2139e3984bdb6df6262d3efa67712c9dfd')
+_DOWNLOADS_DIR=`xdg-user-dir DOWNLOAD`
+if [ ! -f ${PWD}/${_pkg_file_name} ]; then
+ if [ -f $_DOWNLOADS_DIR/${_pkg_file_name} ]; then
+ ln -sfn $_DOWNLOADS_DIR/${_pkg_file_name} ${PWD}
+ else
+ msg2 ""
+ msg2 "The package can be downloaded here: "
+ msg2 "Please remember to put a downloaded package ${_pkg_file_name} into the build directory ${PWD} or $_DOWNLOADS_DIR"
+ msg2 ""
+ fi
+fi
+
prepare() {
install -dm755 build
bsdtar -xf STM32CubeMonitor_lin/${pkgname}_${pkgver}_amd64.deb -C build