summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 12 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index af2a9cc53930..b73a31c43f4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,47 @@
# Maintainer: Dan Beste <dan.ray.beste@gmail.com>
-# TODO: Include docs!
-
pkgname='stratisd-git'
-_gitname='stratisd'
-pkgver=0.1.1.r39.g91c6498
+pkgver=0.1.2.r11.g3a8dbd9
pkgrel=1
pkgdesc='Stratis is a new tool that meets the needs of Red Hat Enterprise Linux (RHEL) users calling for an easily configured, tightly integrated solution for storage that works within the existing Red Hat storage management stack.'
arch=('i686' 'x86_64')
url='https://stratis-storage.github.io/'
license=('MPL2')
makedepends=('cargo' 'git' 'rust')
-provides=("${_gitname}")
-conflicts=("${_gitname}")
+provides=("${pkgname/-git}")
+conflicts=("${pkgname/-git}")
source=('git+https://github.com/stratis-storage/stratisd.git')
sha256sums=('SKIP')
pkgver() {
- cd "${_gitname}"
+ cd "${pkgname/-git}"
git describe --long --tags \
| sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${_gitname}"
+ cd "${pkgname/-git}"
- make
+ cargo build --release
+ cargo doc --no-deps
}
check() {
- cd "${_gitname}"
+ cd "${pkgname/-git}"
make test
}
package() {
- cd "${_gitname}"
+ cd "${pkgname/-git}"
install -d -m 755 "${pkgdir}/usr/bin/"
install -d -m 755 "${pkgdir}/usr/share/doc/"
- install -d -m 755 "${pkgdir}/usr/share/licenses/${_gitname}"
+ install -d -m 755 "${pkgdir}/usr/share/licenses/${pkgname/-git}"
- install -m 755 target/release/${_gitname} "${pkgdir}/usr/bin/${_gitname}"
- install -m 644 LICENSE "${pkgdir}/usr/share/licenses/${_gitname}/LICENSE"
+ install -m 755 target/release/${pkgname/-git} "${pkgdir}/usr/bin/${pkgname/-git}"
+ install -m 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname/-git}/LICENSE"
cp -r target/doc/* "${pkgdir}/usr/share/doc/"
}