summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 5 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6798c2eafcf7..dadc38f6984f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,18 @@
# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
-_use_pycrypto="no"
-_use_pycountry="no"
-
pkgname=streamlink-git
-pkgver=1.3.0.r0.g9253fc51
+pkgver=1.4.1.r5.g3f24fde7
pkgrel=1
pkgdesc='CLI program that launches streams from various streaming services in a custom video player (livestreamer fork)'
arch=('any')
url='https://streamlink.github.io/'
license=('BSD')
-
-if [ "$_use_pycrypto" = "yes" ]; then
- depends+=('python-crypto')
- conflicts+=('python-pycryptodome')
-else
- depends+=('python-pycryptodome')
-fi
-
-if [ "$_use_pycountry" = "yes" ]; then
- depends+=('python-pycountry')
-else
- depends+=('python-iso3166' 'python-iso639')
-fi
-
-depends+=("python-"{isodate,pysocks,requests,websocket-client} 'rtmpdump')
+depends=("python-"{pycryptodome,isodate,pycountry,requests,pysocks,websocket-client} 'rtmpdump')
checkdepends=("python-"{freezegun,mock,pytest,requests-mock})
-makedepends=('git' 'python-recommonmark')
+makedepends=("python-"{recommonmark,setuptools,sphinx} 'git')
optdepends=('ffmpeg: Required to play streams that are made up of separate audio and video streams, eg. YouTube 1080p+')
provides=("${pkgname%-*}")
-conflicts+=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
source=("${pkgname%-*}::git+https://github.com/streamlink/streamlink.git")
sha512sums=('SKIP')
@@ -40,14 +23,7 @@ pkgver() {
build() {
cd "${pkgname%-*}"
- if [ "$_use_pycrypto" = "yes" ]; then
- msg "Using pycrypto..."
- export STREAMLINK_USE_PYCRYPTO="true"
- fi
- if [ "$_use_pycountry" = "yes" ]; then
- msg "Using pycountry..."
- export STREAMLINK_USE_PYCOUNTRY="true"
- fi
+ export STREAMLINK_USE_PYCOUNTRY="true"
python setup.py build
python setup.py build_sphinx -b man
}