summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6009b0f6bfd0..27fcf5a32a93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
pkgname=streamlink-git
-pkgver=0.1.0.r15.ga6c70f7
+pkgver=0.1.0.r20.g2808eb6
pkgrel=1
pkgdesc='CLI program that launches streams from various streaming services in a custom video player (livestreamer fork)'
arch=('any')
url='https://streamlink.github.io/'
license=('BSD')
-depends=('python-pycryptodome' 'python-requests<2.12' 'python-setuptools' 'rtmpdump')
+depends=('python-pycryptodome' 'python-requests' 'python-setuptools' 'rtmpdump')
makedepends=('git' 'python-sphinx')
optdepends=('python-librtmp: Required by the ustreamtv plugin to be able to use non-mobile streams.')
provides=('streamlink')
@@ -22,6 +22,7 @@ pkgver() {
build() {
cd streamlink
+ sed -i 's/requests>=1.0,<2.12.0/requests>=1.0,<3.0/' setup.py
python setup.py build_sphinx -b man
}