summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD61
1 files changed, 29 insertions, 32 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 18c34ffa7f78..4f93132e5a44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,58 +1,53 @@
-# Maintainer: Daniel Bermond < gmail-com: danielbermond >
+# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=stremio
-pkgver=4.4.77
-pkgrel=2
+pkgver=4.4.168
+pkgrel=1
pkgdesc='A one-stop hub for video content aggregation (Movies, TV shows, series, live television or web channels)'
arch=('x86_64')
url='https://www.stremio.com/'
-license=('GPL3')
-depends=('mpv' 'qt5-webengine' 'qt5-declarative' 'qt5-webchannel' 'qt5-quickcontrols'
- 'qt5-quickcontrols2' 'qt5-translations' 'nodejs')
-makedepends=('git' 'librsvg')
-source=("git+https://github.com/Stremio/stremio-shell.git#tag=${pkgver}"
+license=('GPL-3.0-only')
+depends=('mpv' 'nodejs' 'openssl' 'qt5-base' 'qt5-declarative' 'qt5-webengine'
+ 'qt5-quickcontrols' 'qt5-quickcontrols2' 'qt5-translations' 'qt5-webchannel'
+ 'hicolor-icon-theme')
+makedepends=('git' 'cmake' 'librsvg')
+source=("git+https://github.com/Stremio/stremio-shell.git#tag=v${pkgver}"
'git+https://github.com/Ivshti/libmpv.git'
'git+https://github.com/itay-grudev/SingleApplication.git'
'git+https://github.com/Ivshti/razerchroma.git'
"stremio-${pkgver}-server.js"::"https://dl.strem.io/four/v${pkgver}/server.js"
"stremio-${pkgver}-stremio.asar"::"https://dl.strem.io/four/v${pkgver}/stremio.asar"
- 'stremio-do-not-download-server-js.patch')
-sha256sums=('SKIP'
+ '010-stremio-do-not-download-server-js.patch')
+sha256sums=('30b65909f100ed31b406280077b54fed9a50602dec28c540c6c0dc0c02b5597e'
'SKIP'
'SKIP'
'SKIP'
- '2ccab494d975363fd16b61d51527995c7d452d66e69dd1bd9ffa2a4d11fb7191'
- 'e2295734bb6ff6ecf9b1fd423f89fccc617a11a86310bf44b03301f452650067'
- 'b1febe31374eaceefc1f869d574a00f7f5414eafa8b5d0a92a5f511078ba3add')
+ '683de7890a60ab512264b69c9c41609aa515f9b738aef18df4803ef53e17175d'
+ 'de34860e99a78f37e8c5568e56e605bc04e1853d48d2102421fcf2331a42d207'
+ 'b5eff88b30d8c6030e36ca4949ebf6ff9515efbedc0b9bc748110cd1fbc0671a')
prepare() {
- cd stremio-shell
-
- git submodule init
- git config --local submodule.deps/libmpv.url "${srcdir}/libmpv"
- git config --local submodule.deps/singleapplication.url "${srcdir}/SingleApplication"
- git config --local submodule.deps/chroma.url "${srcdir}/razerchroma"
- git submodule update
+ git -C stremio-shell submodule init
+ git -C stremio-shell config --local submodule.deps/libmpv.url "${srcdir}/libmpv"
+ git -C stremio-shell config --local submodule.deps/singleapplication.url "${srcdir}/SingleApplication"
+ git -C stremio-shell config --local submodule.deps/chroma.url "${srcdir}/razerchroma"
+ git -C stremio-shell -c protocol.file.allow='always' submodule update
# do not download server.js during 'make'
- ln -s "${srcdir}/stremio-${pkgver}-server.js" server.js
- patch -Np1 -i "${srcdir}/stremio-do-not-download-server-js.patch"
+ ln -s "../stremio-${pkgver}-server.js" stremio-shell/server.js
+ patch -d stremio-shell -Np1 -i "${srcdir}/010-stremio-do-not-download-server-js.patch"
}
build() {
- cd stremio-shell
-
- make -f release.makefile PREFIX="$pkgdir"
+ make -C stremio-shell -f release.makefile PREFIX="$pkgdir"
}
package() {
- cd stremio-shell
-
- make -f release.makefile PREFIX="$pkgdir" install
+ make -C stremio-shell -f release.makefile PREFIX="$pkgdir" install
# streaming server files
- install -D -m644 "${srcdir}/stremio-${pkgver}-server.js" "${pkgdir}/opt/stremio/server.js"
- install -D -m644 "${srcdir}/stremio-${pkgver}-stremio.asar" "${pkgdir}/opt/stremio/stremio.asar"
+ install -D -m644 "stremio-${pkgver}-server.js" "${pkgdir}/opt/stremio/server.js"
+ install -D -m644 "stremio-${pkgver}-stremio.asar" "${pkgdir}/opt/stremio/stremio.asar"
# binary and desktop file
mkdir -p "${pkgdir}/usr/"{bin,share/applications}
@@ -60,13 +55,15 @@ package() {
ln -s ../../../opt/stremio/smartcode-stremio.desktop "${pkgdir}/usr/share/applications/smartcode-stremio.desktop"
# icons
+ local _file
local _res
- for _res in 16 22 24 32 64 128
+ while read -r -d '' _file
do
+ _res="$(printf '%s' "$_file" | sed 's/\.png$//;s/^.*_//')"
mkdir -p "${pkgdir}/usr/share/icons/hicolor/${_res}x${_res}/apps"
ln -s ../../../../../../opt/stremio/icons/smartcode-stremio_${_res}.png \
"${pkgdir}/usr/share/icons/hicolor/${_res}x${_res}/apps/smartcode-stremio.png"
ln -s ../../../../../../opt/stremio/icons/smartcode-stremio-tray_${_res}.png \
"${pkgdir}/usr/share/icons/hicolor/${_res}x${_res}/apps/smartcode-stremio-tray.png"
- done
+ done < <(find "${pkgdir}/opt/stremio/icons" -maxdepth 1 -type f -name 'smartcode-stremio_*.png' -print0)
}