summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6704ca702f28..aa2a3fd44f7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,12 +29,12 @@ _ensure_local_nvm() {
unset npm_config_prefix
export NVM_DIR=${srcdir}/.nvm
. /usr/share/nvm/init-nvm.sh
+ _node_version=$(jq -r '.engines.node' package.json)
}
prepare() {
cd "${srcdir}/${_pkgname}"
_ensure_local_nvm
- _node_version=$(jq -r '.engines.node' package.json)
# ` || false` is a workaround until this upstream fix is released:
# https://github.com/nvm-sh/nvm/pull/2698
nvm ls "$_node_version" &>/dev/null ||