summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b52e25ed5339
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Andreas Kurth <archlinux@akurth.net>
+pkgname='strix-claw'
+pkgver=r6.78eef095b3
+pkgrel=1
+pkgdesc="Daemon that prevents freezes of Asus Strix Claw mice"
+arch=('x86_64')
+url='https://github.com/hamer/strix-claw'
+license=('GPL3')
+depends=('libusb>=1.0')
+makedepends=('git')
+source=("$pkgname-$pkgver::git+$url#commit=78eef095b3968124bbf1f58ebd54a7d52403f805"
+ 'Makefile-CFLAGS_LDFLAGS.patch'
+ 'strix-claw.service-binary_path.patch')
+sha256sums=('SKIP'
+ '069fce3bf1221e356beb16b7a78f207e8f3f851e5708144a473941ecc725072d'
+ 'e8895bac5b8b92815829c1708c99591e6522917804ec00e335dbd977a3fae727')
+
+pkgver() {
+ cd "$pkgname-$pkgver"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ for patch_file in "$srcdir"/*.patch; do
+ patch --forward -i "$patch_file"
+ done
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -D -t "$pkgdir/usr/lib" strix-claw
+ install -D -m 644 -t "$pkgdir/usr/lib/systemd/system" strix-claw.service
+}