summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a258edb21236..5a03c4b6d39c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,8 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
-#
-# Any suggestions welcome; please submit paches via Github:
-# https://github.com/alerque/aur/tree/master/git-annex-bin
pkgname=stund
pkgver=0.97
-pkgrel=3
+pkgrel=4
pkgdesc="STUN Server and Client"
url="http://downloads.sourceforge.net/project/stun/stun/"
source=("http://downloads.sourceforge.net/project/stun/stun/${pkgver}/${pkgname}-${pkgver}.tgz"
@@ -18,17 +15,22 @@ license=('GPL2')
sha256sums=('83e1bf9c21399244c5e8ad19789121a3537399d6523a887a5abc6187adcdb1d7'
'8c09a0acc8797bf8060ed84ca4e0d6ca242447ea8cbee6c28904a7056773030d')
-package() {
- cd "$srcdir/$pkgname"
-
- if [ `uname -m` = 'x86_64' ]; then
- patch < $srcdir/fix_non_i386.patch
+prepare() {
+ cd "${pkgname}"
+ if [[ $(uname -m) = x86_64 ]]; then
+ patch < ${srcdir}/fix_non_i386.patch
fi
+}
- make all || return 1
+build() {
+ cd "${pkgname}"
+ make all
+}
- mkdir -p $pkgdir/usr/bin
+package() {
+ cd "${pkgname}"
+ install -Ddm755 ${pkgdir}/usr/bin
- cp server $pkgdir/usr/bin/stund || return 1
- cp client $pkgdir/usr/bin/stunc || return 1
+ install -Dm0755 server ${pkgdir}/usr/bin/stund
+ install -Dm0755 client ${pkgdir}/usr/bin/stunc
}