summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 421fc03c8705..440ac3ccb967 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=subsurface-git
_pkgname=subsurface
-pkgver=20170329.09b5f9b9
+pkgver=20170403.8c94fa26
pkgrel=1
pkgdesc='Divelog program'
url='https://subsurface-divelog.org/'
@@ -13,8 +13,10 @@ makedepends=('git' 'cmake' 'asciidoc')
depends=('libzip' 'libxml2' 'libxslt' 'sqlite' 'libusb' 'libgit2'
'subsurface-libdc' 'subsurface-marble'
'qt5-connectivity' 'grantlee')
-source=('git://git.subsurface-divelog.org/subsurface')
-sha256sums=('SKIP')
+source=('git://git.subsurface-divelog.org/subsurface'
+ 'headers.patch')
+sha256sums=('SKIP'
+ 'fbcbf99294e9ba9ef134eb04b832cca4b19355070020f5ee2984ce739e8f0a6c')
provides=('subsurface')
conflicts=('subsurface')
@@ -27,6 +29,7 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
sed 's:<marble:<subsurface/marble:g' -i desktop-widgets/globe.*
+ patch -p1 -i ../headers.patch
}
build() {